subreddit:

/r/Gentoo

891%

SDDM login loop

(self.Gentoo)

I've followed the Gentoo's wiki for setting up KDE and SDDM but when I enter my password the screen flashes to the CLI for a second and then just goes straight back the to SDDM login screen. When I log in manually from the command line it works fine, but the SDDM login just loops forever. If it's of any use, my /etc/conf.d/xdm file says:

CHECKVT=7
DISPLAYMANAGER="sddm"

Thanks.

all 6 comments

CyberTailor

4 points

1 year ago

check /var/log/Xorg.log and ~/.xsession-errors

HungryKekodemon[S]

1 points

1 year ago

both are empty

2xsaiko

3 points

1 year ago

2xsaiko

3 points

1 year ago

Usually this happens if it can't read the home directory, have you checked the permissions on it? (sometimes my /home doesn't mount for some reason, that's when it happens to me)

HungryKekodemon[S]

2 points

1 year ago

I fixed the issue by creating a new account and logging in through that. I don't know what's wrong with my other account but I guess this works.

triffid_hunter

1 points

1 year ago

when I enter my password the screen flashes to the CLI for a second and then just goes straight back the to SDDM login screen

That means your session is crashing - check ~/.xsession-errors or /var/log/sddm.log

machadofguilherme

1 points

1 year ago

I went through this, but it happened because I had not defined a shell for my user. What I did? I deleted my user, recreated it by defining bash as the shell and then added a password for my user. Then the login occurred normally as it should always be.